The ClojureWerkz Blog

News and updates about ClojureWerkz projects

Clojure 1.5 Compatibility of ClojureWerkz Projects


Clojure 1.5 is finally released. ClojureWerkz projects are compatible with it. It’s probably sunny outside, too.

Feel free to upgrade today!

Clojure 1.5 and ClojureWerkz

Clojure 1.5 is finally releases. While not a groundbreaking release, 1.5 brings more new features than 1.4 did. So, it’s natural to expect that many developers will consider upgrading to it soon.

One of the main goals of ClojureWerkz has always been making sure our libraries work with multiple Clojure versions (currently 1.3+). To hold to the promise, we run tests against multiple Clojure versions during development and on One of the versions is the master Clojure snapshot.

Starting with 1.5.0-RC* releases, we started testing several of our projects against it:

We are happy to report that none of those projects required any modifications to pass their test suites on Clojure 1.5.0.

Michael on behalf of the ClojureWerkz Team.